WineHQ проблема с Ubuntu 22.04

С обновлением Ubuntu 20.04 на 22.04 пропала возможность запуска целой кучи маленьких полезных виндовых программулек. Причина – не инсталлится Wine.

$ sudo apt install --install-recommends winehq-stable wine-stable
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgphoto2-6:i386 : Depends: libgd3:i386 (>= 2.1.0~alpha~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Пришлось нормально так попотеть, чтобы понять в чём проблема и найти решение.

Примерно раз в месяц, в течение года я возвращался к этому вопросу вноь и вновь, но оно всё не находилось. Решения которые предлагались, в том числе в интернетах, пытались снести все пакеты которые используют libgd3, переустановить её и по-новой вернуть софт. Что-то стрёмно, на этот риск я пойтить не решался.

И вот спустя почти год заприметил возможность деградировать версию либы. И всё сложилось. Магия в следующей строке.

$ sudo apt-get install libgd3=2.3.0-2ubuntu2 libgd3:i386=2.3.0-2ubuntu2
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
libgd3 is already the newest version (2.3.0-2ubuntu2).
The following packages were automatically installed and are no longer required:
  libavif13 libgav1-0 libyuv0
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libdeflate0:i386 libexpat1:i386 libfontconfig1:i386 libjbig0:i386 libjpeg-turbo8:i386
  libjpeg8:i386 liblzma5:i386 libtiff5:i386 libuuid1:i386 libwebp7:i386 libxpm4:i386 libzstd1:i386
Suggested packages:
  libgd-tools:i386
The following NEW packages will be installed:
  libdeflate0:i386 libexpat1:i386 libfontconfig1:i386 libgd3:i386 libjbig0:i386 libjpeg-turbo8:i386
  libjpeg8:i386 liblzma5:i386 libtiff5:i386 libuuid1:i386 libwebp7:i386 libxpm4:i386 libzstd1:i386
0 upgraded, 13 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,508 kB of archives.
After this operation, 4,651 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
...
...
...
Complete.

Теперь делаем всё как обычно и получаем работабщий WineHQ.

$ sudo apt install --install-recommends winehq-stable wine-stable
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
...
Complete.

Кто сегодня молодец? Я молодец. Взял с полки не просто пирожок, а ПИРОЖОК.

en_USEnglish